# Table of Contents

Table of Contents.................................................................................................................. I
Revision History...................................................................................................................... II
Introduction .............................................................................................................................. 1
Setting Up IR Control ............................................................................................................... 1
Setting Up Via! Tools ............................................................................................................... 1
Volume Control in Via! Tools .................................................................................................. 2
Setting Up the AudioReQuest ............................................................................................... 2
  Firmware Requirements: ..................................................................................................... 2
  AudioReQuest Connections and Settings: .......................................................................... 2
  Enabling Enhanced Themes: ............................................................................................... 2
  Selecting the Elan Theme ................................................................................................... 3
Appendix A – Troubleshooting............................................................................................... 4
Appendix B – Adding AudioReQuest to an Existing Program............................................. 5
Appendix C – Integrating Elan with Older AudioReRequests ............................................ 6
  Connect AudioReQuest to Elan VIA and HDD Systems: .................................................. 7
  VIA!TOOLS Setup: ............................................................................................................. 7
  AudioReQuest Setup: .......................................................................................................... 7
  Visuals: ............................................................................................................................... 8
## Revision History

<table>
<thead>
<tr>
<th>Revision Number</th>
<th>Changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>Initial Version</td>
</tr>
<tr>
<td>2.2.0</td>
<td>Updated to support AudioReQuest v2.2.0</td>
</tr>
</tbody>
</table>
Introduction

AudioReQuest firmware v2.2.0 introduced a powerful new Enhanced Theme Selector to allow you to select the user interface that best suits your needs. Along with the Enhanced Touchpanel and Enhanced TV themes, ReQuest designed an all new user experience for the Elan Via! touchscreen. This new interface includes new graphics, support for Multi-Zone with the F.Series and S.Series, added commands, and a new layout. The information provided in this document will help you get your new AudioReQuest set up with Elan in no time!

Setting Up IR Control

To control the AudioReQuest via IR, you can place a stick-on type IR emitter on the front of the unit or take advantage of the 1/8\textsuperscript{th} inch mini jack on the rear of the unit. The pinout for the mini jack port is listed below.

<table>
<thead>
<tr>
<th>Tip</th>
<th>Signal</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ring</td>
<td>Ground</td>
</tr>
<tr>
<td>Sleeve</td>
<td>Not Connected</td>
</tr>
</tbody>
</table>

Setting Up Via! Tools

The new Enhanced Elan User Interface requires new IR commands and a new overlay in order to function correctly. ReQuest has created a sample project that contains everything you need and is available for download under the Support→Integration section at [www.ReQuest.com](http://www.ReQuest.com). This sample file also contains the overlay page (*AudioReQuest_v220.OFT*) and the IR Library file (*ReQuest_AudioReQuest_v220.irm*) if you choose to incorporate this interface into an existing project (see Appendix B for information).

To get started, follow these simple steps:

1. Open Via! Tools
2. Choose Import from the Project pull-down menu

To verify that the import was successful, click on the Layout tab, select the AudioReQuest_v2_2_0 page, and verify that the layout looks like the one pictured below.

At this point you are ready to test it and add other components to the system. It is recommended that you follow this process to ensure that you get the correct IR library and overlay.
Volume Control in Via! Tools

It is recommended to change the Volume controls in the AudioReQuest overlay to match the volume control of your Z630, HD MCU, preamp, or receiver’s volume up/down commands for that Via panel’s zone. Repeat for every Via panel in every zone.

Setting Up the AudioReQuest

Firmware Requirements:
The first step to configuring the AudioReQuest for use with the new Enhanced Elan Via! interface is to ensure that you are running the proper firmware. The new Elan interface requires AudioReQuest firmware 2.2.0 or higher. To check your firmware version, go to Menu→System Information on the AudioReQuest and look for Software Version. If the firmware version is lower than 2.2.0 but not lower than 2.0.0, you can perform a software update online by going to Menu→Settings→Advanced→Software Update Online. If the firmware is lower than 2.0.0 (i.e. 1.9.32), you can use the older AudioReQuest Elan interface (see Appendix C) or contact ReQuest technical support and ask how you can upgrade your AudioReQuest to the latest version.

AudioReQuest Connections and Settings:

For initial setup, the AudioReQuest composite video output must be connect to either a TV or a VIA! Touch Panel. You must also have the AudioReQuest remote control handy in order to set the system up.

AUDIOREQUEST SETUP FUNCTIONS CANNOT BE ACCOMPLISHED FROM THE VIA! PANEL!

To configure the AudioReQuest system’s audio output for FIXED:

a. Using the AudioReQuest system’s remote control, press MENU.
b. Navigate to SETTINGS and then VOLUME LOCK.
c. Make sure the VOLUME LOCK is enabled. (Default ON)

2. The AudioReQuest system’s screen-saver feature must be DISABLED:

a. Press MENU on the AudioReQuest system’s remote control.
b. Navigate to SETTINGS and then SET SCREEN SAVER OPTIONS.
c. Make sure the SCREEN SAVER option is unchecked.

Enabling Enhanced Themes:

Once you have verified that you are running the proper firmware, you can now enable the Enhanced Themes.

1. Go to Menu→Settings→Video Settings→Screen Selection
2. If either Enhanced TV or Enhanced Touchpanel is selected, skip to Selecting the Elan Theme below
3. If Traditional Screens is selected:
   a. Select one of the other options (Enhanced TV or Enhanced Touchpanel)
   b. Scroll to OK and press Enter

It will ask you if you want to reboot Now or Later. Select Now

Once the unit finishing rebooting, proceed to Selecting the Elan Theme
Selecting the Elan Theme
1. Issue the Themes command from the IR remote by holding the Alt button and pressing the number 7
2. This will display the Theme Selector on the video display (TV, touchpanel, etc)
3. Using the arrow keys on the remote, select Elan Touchscreen and pressed Enter
4. This will display the new Enhanced Elan Interface on the touchpanel.

At this point you are ready to test it out. If you have any problems or if you are not seeing any video on the touchpanel, please refer to Appendix A – Troubleshooting for more information or contact ReQuest technical support at (800) 236-2812.
Appendix A – Troubleshooting

1. I don’t see anything on my touch panel when I select the AudioReQuest from the source page
   The AudioReQuest will not enable the Composite or S-Video outputs if it does not detect a valid display device during boot-up. There are a couple of ways to resolve this.
   1. Make sure the Elan panel’s load jumper is set to 75 Ohm terminated.
   2. Ensure that the video is plugged in before the unit is powered on and that the Elan panel is powered on.
   3. If the AudioReQuest is already powered on, ensure that video is now connected and that the Elan panel is powered on. Press Alt-T on the IR remote or the ‘equals’ sign on the keyboard.
   4. Go to Menu→Settings→Feature Settings→TV Lock and make sure TV Lock is Enabled.

2. I see the ReQuest video on my touch panel, but none of the buttons work
   This is usually the result of a non-existent or incomplete overlay. Verify the following:
   1. If you are using the IR port in the back of the unit, check your AudioReQuest serial number. If the serial number starts with ARQ40 and the last 4 digits are lower than 1560, then your AudioReQuest may have a hardware problem. This problem only affects Elan control systems using the rear IR port. Contact ReQuest technical support to verify that you have an affected unit. If you do, you can then decide to have it repaired or simply use a stick-on type emitter on the front of the AudioReQuest unit.
   2. In Via! Tools, switch to the Router page and select the ReQuest source button.
   3. Under Programmed sequence, verify that it is set to Switch to Video mode w/Overlay and that it is set to select the correct overlay when you choose the ReQuest.
   4. Switch to the Overlay tab and verify that the overlay page for the AudioReQuest looks like the sample on page 1 above
   5. Select one of the non-functioning buttons on the overlay page and verify that there is an IR command assigned to that button.
   6. Verify that the IR commands are being transmitted by the Elan system. To do this, try a different emitter or IR cable (preferably one that you know has worked in the past). If you have another AudioReQuest, hook that up and see if it responds to the IR commands. Grab the handheld remote and make sure that it works.

3. I can’t get to the Enhanced Theme Selector. The Themes command on the IR Remote or Keyboard does nothing or simply cycles to the next theme
   1. Verify your firmware version. You MUST be running firmware 2.2.0 or higher on your AudioReQuest in order to use the Enhanced Theme Selector. If your firmware is version 2.0.0 or higher you can perform an online software upgrade (Menu→Settings→Advanced→Software Update Online). If you firmware is lower than 2.0.0, you will need to contact ReQuest for an upgrade or use the older Elan interface (See Appendix C).
   2. Verify that you are in Enhanced Themes mode by going to Menu→Settings→Video Settings→Screen Selection and selecting Enhanced TV or Enhanced Touchpanel.
   3. Reboot the AudioReQuest.
Appendix B – Adding AudioReQuest to an Existing Program

This section explains how to integrate the AudioReQuest controls into an existing Elan system. These steps can also be used to upgrade an older Elan program to use the new interface.

In the steps below you will occasionally see [Elan Root Folder] used when describing where to copy certain files. This folder is typically C:\Program Files\ELAN Home Systems\ELAN Configuration, however your installation may be slightly different. Adjust the directions as necessary to suit your needs.

1. Unzip the Elan Demo Program v2.2.0 that you downloaded from www.ReQuest.com into a temporary folder (for example, on your Desktop)
2. Locate the file entitled ReQuest_AudioReQuest_v220.irt and copy it to: [Elan Root Folder] \Remote Files
3. Locate the file entitled AudioReQuest_v220.oft and copy it to: [Elan Root Folder] \Templates\Function Pages
4. Open the Vial Tools project to which you wish to add the AudioReQuest controls
   NOTE: If you are upgrading an existing project, skip to step 9
5. Select the Layout tab and click Add/Remove/Save under Source Buttons
6. Select an open slot, click the New source button, and give the new source a name
7. Repeat the above steps for all AudioReQuest Zones you are adding
   4 Zones for an F4, 2 Zones for an F2, 1 Zone for any other model
8. When finished, click DONE
9. Select the Overlay tab
10. Click Add/Remove/Save
11. Click Add page from a file
12. Enter a descriptive name for the overlay and click OK
13. In the Open dialog, select AudioReQuest_v220.oft and click Open
   NOTE: It should default to the correct directory. If not, browse to: [Elan Root Folder] \Templates\Function Pages to find the file
14. Select the new page in the list and verify that the button layout looks like the sample pictured on Page 1 above
15. Select the Router tab
16. Select the first AudioReQuest source button
17. On right right-hand side, under Edit sequence, click the Edit sequence button
18. Click the Switch to video mode with overlay button and select the new overlay page from the list
19. Click the IR command button
20. In the dialog that opens, expand the REQUEST category and select AudioReQuest_v220.irt
21. In the lower window, select the Switch to Zone X signal where X is the zone number to which the selected source button connects
22. Click Add IR command then click Done
23. Repeat steps 17-22 for each AudioReQuest source button
24. When finished, save, upload, and test the program
Appendix C – Integrating Elan with Older AudioReQuests

Introduction:
This section explains how to set up an older AudioReQuest (firmware 1.9.32 or earlier) to work with an Elan system. If your AudioReQuest is running firmware 2.0.0 or higher, upgrade to the latest version and follow the instructions above to get the best user experience.

![AudioReQuest PLAYER and NAVIGATOR GUI, ELAN Theme.](image1)

**Figure 1** - The AudioReQuest PLAYER and NAVIGATOR GUI, ELAN Theme.

![AudioReQuest PLAYER and NAVIGATOR GUI, ELAN 2 Theme.](image2)

**Figure 2** - The AudioReQuest PLAYER and NAVIGATOR GUI, ELAN 2 Theme.
Connect AudioReQuest to Elan VIA and HDD Systems:

Connect the composite video of each AudioReQuest Pro and/or Zone to the HDD or other AV switch. For single AudioReQuest and VIA! panel applications, connect the composite video directly to the VIA! Touch panel.

Connect the IR emitters of the Elan VIA panel or IR switch to the IR jack on the back of the ARQ Pro or Zone. Please refer to the chart for IR pin-out. Do not attach powered emitters to the jack.

Note: Both ARQ Pro and ARQ1-Pro have front IR receivers. ARQ1-Pro units do not have a rear IR jack. ARQ-Zones have a rear IR jack and have begin shipping with front IR receivers as well.

VIA!TOOLS Setup:

AudioReQuest Music Servers are set up on the VIA!TOOLS 2.0 ‘Layout’ screen.

1. Select SOURCE BUTTONS – ADD/REMOVE/SAVE.
2. Select an available source button location (----).
3. Click on INSERT AUDIOREQUEST.
4. Press OK, then DONE. A source button named ‘ReQuest’ will automatically be created.

NOTE: VIA!TOOLS 2.0 does not support the use of both the AudioReQuest system and VIA!Music ON THE SAME PANEL. However, you may mix and match AudioReQuest and VIA!Music on different VIA! Panels within the same system.

AudioReQuest Setup:

For initial setup, the AudioReQuest composite video output must be connect to either a TV or a VIA! Touch Panel. You must also have the AudioReQuest remote control handy in order to set the system up.

AUDIOREQUEST SETUP FUNCTIONS CANNOT BE ACCOMPLISHED FROM THE VIA! PANEL!

1. AudioReQuest systems feature two software configurable AUDIO OUTPUT options – FIXED and VARIABLE. ELAN recommends that the FIXED output be utilized in most installations. This will enable the AudioReQuest system to be utilized as a standard source component, and will enable the VIA!TOOLS AUTOBUILD function to map your Z630, HD MCU, preamp, or receiver’s volume up/down commands to the VOLUME UP/DOWN buttons on the AudioReQuest system’s GUI when displayed on the VIA! Panel.

To configure the AudioReQuest system’s audio output for FIXED:

a. Using the AudioReQuest system’s remote control, press MENU.

b. Navigate to SETTINGS and then VOLUME LOCK.

c. Make sure the VOLUME LOCK is enabled. (Default ON)
3. The AudioReQuest system’s screen-saver feature must be DISABLED:
   d. Press MENU on the AudioReQuest system’s remote control.
   e. Navigate to SETTINGS and then SET SCREEN SAVER OPTIONS.
   f. Make sure the SCREEN SAVER option is unchecked.

4. Downloading and Installing the VIA!/AudioReQuest GUI
To install the new VIA!/AudioReQuest GUI into an AudioReQuest server, AudioReQuest firmware version 1.5.91 or later must be installed. To check the version, go to Menu/System Information on the AudioReQuest. If you need to update the firmware, perform an online update or request an update CD from ReQuest.

Follow the steps to change to the Elan Theme:
   a. On the AudioReQuest remote press ALT-7 to change themes.
   b. Continue to change themes and choose between Elan theme (available on version 1.5.91 or later) or Elan 2 Theme (available on version 1.6.0 or later).

**Visuals:**

![Virtual Buttons in Visual mode. (NOTE: Buttons are not actually shown in visuals)](image)

*With early version of VIA!TOOLS 2.0, the VIA Panel may send out double IR commands with one or more AudioReRequests are connected to a VIA panel. Contact Elan for an updated version if this occurs.*

*Similarly, double commands may be sent with AudioReQuest firmware version 1.6.0. Firmware 1.6.1 addresses this problem.*

For help or additional information on AudioReQuest systems, call ReQuest MultiMedia at (800) 236-2812. For help or additional information on ELAN VIA! Touch Panels, VIA!TOOLS 2.0 or other ELAN products, please call ELAN Technical Support at (859) 269-7760.